We are currently experiencing intermittent issues

Major incident TextAlert TextCampaign TextEmail TextGateway TextInbound TextOnline TextPremium TextSurvey
2025-11-18 11:48 GMT · 3 hours, 30 minutes

Updates

Resolved

The issue has now been resolved

November 18, 2025 · 15:17 GMT
Issue

We are currently experiencing intermittent issues with one of our providers, which is affecting access to our platform. Investigations are on-going.

An update will be announced as soon as we have more details.

November 18, 2025 · 11:48 GMT

← Back