TextAnywhere - Email service disruption

Minor incident TextEmail
2025-11-12 12:42 GMT · 1 day, 1 hour, 38 minutes

Updates

Resolved

Issue resolved - Please contact us if you experience any issues.

November 13, 2025 · 14:20 GMT
Investigating

We are still working through the problem so expect continued delays. We will update when we have further information.

November 13, 2025 · 14:19 GMT
Investigating

Unfortunately, we are still having delays in this service. We will update when we have further information.

November 12, 2025 · 17:31 GMT
Issue

We are aware of disruption for Email related services on TextAnywhere. We are actively investigating, and apologise for any inconvenience.

November 12, 2025 · 12:42 GMT

← Back